奇易论坛(原Fiddler)

 找回密码
 我要注册

QQ登录

只需一步,快速开始

查看: 262|回复: 5

[建议] 释放自身内存 () 这个子程序 按钮下点击能效, 主窗口尺寸g...

[复制链接]

签到天数: 1

该用户今日未签到

发表于 2019-6-27 01:54:53 | 显示全部楼层 |阅读模式
易语言调试运行情况和静态编译后下: 易语言5.81 学习板...你懂得!

释放自身内存 ()...
1. 这个是压入虚拟内存么?(set -1,-1,-1 那是个伪优化内存...)
这个问题对我很重要, 我用webui, 一个表1万左右数据, 如果都是压入虚拟内存,最后会奔溃的..请开发者告知! 是的话我就不用这个子程序了.


2. 我易窗口可调尺寸, wke绑定在外形框上.. 主窗口调节size,外形框(wke)也跟着调节size. 我目前是在尺寸改变完下面加了 释放自身内存 (),
在任务管理器里面发现内存变化不大(可能就减少1-3MB) 用时钟去调用这个子程序也是这样.

我1万行list数据 默认是70MB左右.
但是点击按钮 释放自身内存 () 内存可以降到2MB不到。

所以,这算bug还是什么?为何调用差距这么大?
最后, 可能真的需要知道....释放自身内存 ()的机制, 单线程运作的?还是绑定在哪...


谢谢. (本来想录个gif上传证明的..不知道现在用啥软件录...)
==============================================
.版本 2
.支持库 spec

.子程序 __启动窗口_尺寸被改变
.局部变量 外宽度, 整数型
.局部变量 外高度, 整数型

外宽度 = _启动窗口.宽度
外高度 = _启动窗口.高度
调试输出 (外宽度, 外高度)
外形框1.宽度 = 外宽度 - 外形框1.左边 - 20
外形框1.高度 = 外高度 - 外形框1.顶边 - 42

时钟1.时钟周期 = 100

.子程序 _时钟1_周期事件

释放自身内存 ()
调试输出 (“释放了”)
时钟1.时钟周期 = 0


签到天数: 1

该用户今日未签到

 楼主| 发表于 2019-7-9 13:31:07 | 显示全部楼层
诺离 发表于 2019-7-2 07:25
是的,这个用不到释放自身内存 ()

请问下 还原多线程填表(开启网络填表)  这个功能怎么用,需要配合奇易模块还是 浏览模块单独就能用? 没找到对应教程...求传送门

谢谢
回复 支持 反对

使用道具 举报

该用户从未签到

发表于 2019-7-9 11:12:30 | 显示全部楼层
感谢楼主分享
回复 支持 反对

使用道具 举报

该用户从未签到

发表于 2019-7-4 10:44:37 | 显示全部楼层
我看看 厉害不厉害
回复 支持 反对

使用道具 举报

签到天数: 27

该用户今日未签到

 成长值: 10560
发表于 2019-7-2 07:25:10 | 显示全部楼层
是的,这个用不到释放自身内存 ()
回复 支持 反对

使用道具 举报

签到天数: 1

该用户今日未签到

 楼主| 发表于 2019-6-27 01:58:33 | 显示全部楼层
只用的 奇易浏览框模块
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 我要注册

本版积分规则

关闭

奇易论坛推荐上一条 /1 下一条

| Archiver|手机版|小黑屋|奇易论坛  

GMT+8, 2019-12-12 16:02 , Processed in 0.079318 second(s), 29 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表